We've confirmed that systems are stable and performance has returned to expected levels.
Posted Nov 15, 2024 - 07:47 PST
Monitoring
The provider has implemented a fix which appears to have restored performance levels, we're monitoring the situation to assure stability now.
Posted Nov 15, 2024 - 07:36 PST
Identified
A database cloud provider is experiencing unusually high load which is causing degraded performance on certain pages and API endpoints. We're in contact with them and actively working towards a solution.