Artist data is once again being returned as expected, we'll continue to monitor data quality to ensure stability.
Posted Feb 28, 2024 - 19:15 PST
Monitoring
The majority of artists should be returning data as expected once again, accuracy will continue to improve over the next 1-2 hours as fresh data propagates through the system.
Posted Feb 28, 2024 - 17:56 PST
Identified
We're aware of an issue causing some artist data to be returned inaccurately on the dashboard and Developer API, but we've already identified the issue and everything should return to normal within 2 hours.